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Project Information 
 

Project Name: Brockman 4 

Modeller: Kathryn Gall 

Grid: MGA 

Software: Leapfrog Geo 

Version: 4.2.3 

Date: 25th June 2018 

 

Working with Leapfrog Projects 
 

Creating a New Project 

 
When Leapfrog is opened for the first time you will be presented with a blank screen with three key 
options. You can either create a new project, open a project file, or browse for projects within a folder. 
We will start by creating a new project. 

 

 Click New Project... and the Create Project window appears. 

 Navigate to the folder you would like to save the project to, then enter a new project name and 
click OK. 

 
 
Note: For the best performance, Leapfrog projects should be saved to local fixed hard disks, rather than to 
remote drives. Saving to a remote drive may introduce performance or reliability issues with the project. 
 
It is recommended that users save projects to their local fixed hard disks, then save a zipped copy to a 
remote drive to back the project up. 
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The Leapfrog Geo Main Window 
 
The Leapfrog Geo main window is made up of four different windows plus a small toolbar. The Project 
Tree is to the left of the screen, the Scene is in the middle, the Scene List is at the bottom of the screen, 
and the Properties Panel is in the lower right corner. 
 

 
 
The Project Tree contains all the data in the project, as well as the tools for working with that data. It is 
based around a series of Right-Click menus, which can be used to add new and change existing objects. 
 
The Scene displays a 3D view of any objects which have been selected from the Project Tree. 
 
The Scene List displays a list of all objects which are currently in the Scene. The appearance of objects in 
the Scene can be altered in the Scene List. 
 
The Properties Panel contains additional visualisation options which change depending on which objects 
are being visualised in the Scene. 
 
Interacting with the Scene 
 
Mouse Functions in the Scene 
It is recommended that an external mouse is used, rather than your laptop touch pad. The 
mouse controls for Leapfrog are reasonably simple and intuitive: 
 

 Zoom: there are two options. Either use your scroll wheel, or Right-Click and drag the mouse up 
to zoom in, or down to zoom out. 

 Pan: again, there are two options. Either click and hold the scroll wheel or click and hold both the 
left and mouse right buttons at the same time. 

 Rotate: click and hold the left mouse button, then rotate the scene. 

 Centre the scene on a point: either click your scroll button or click both the left and right mouse 
buttons at the same time on the point you would like to centre on. This lets you rotate about and 
zoom in on that point. 
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 Left clicking on any object in the scene firstly highlights that object in the Scene List, and secondly 
lists all its properties in the Scene. For example, clicking on a mesh will list the exact location you 
clicked, as well as its volume, surface area, number of parts, and its name. 
 

Mouse Functions in the Project Tree 
 
The mouse can be used to access all menu options in the Project Tree. 

 Right clicking on a folder lets you import, or create a new object relating to the folder you right 
clicked on. 

 Right clicking on an existing object lets you perform new functions with that object. For 
example, right clicking on an existing points file lets you make a new query, new selection, make 
an evaluation or export the points.  

 Double clicking on an existing object lets you access the current settings of that object. For 
example, by double clicking on an existing set of points, you can view the x, y, and z columns as 
well as any numeric columns which may be present. 

 
Keyboard Shortcuts 
 
There are several keyboard shortcuts. Some of these are very useful, and there are others which are 
used infrequently. A list of the most commonly used shortcut keys is below. 

 

Leapfrog Project Files 
 
A Leapfrog project is made up of several different folders. In the screenshot below, Brockman4.aproj is 
the project file, and Brockman.aproj_data is the database containing the binary code that makes up the 
project. 

 
 

When the project is open in Leapfrog, the Brockman4.lock file will also appear in the folder. The .lock file 
protects the project from being moved while the project is open and from being opened by other 
instances of Leapfrog, which can happen when projects are saved on shared network drives. 
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Saving Leapfrog Projects 
 
Leapfrog projects are saved automatically as you work with them. This means if you exit Leapfrog while 
there are tasks still processing, the tasks will be waiting to resume processing the next time you open that 
project. It can be useful to save separate copies in case you make an error and wish to revert to an earlier 
version of your project. To do this, click on the Leapfrog Geo menu and select Save a Copy. You can also 
Save a Zipped Copy of the project. 
 

 

Top Toolbar 
 
There is a small toolbar above the Scene which contains several useful functions. 
 

 
 
From the left to the right, the functions are as follows: 

 Clear scene: Removes all objects from the Scene. 

 Look: Contains a list of commonly used keyboard functions. 

 Swap slicer and plane: Swaps between the slicer and the plane (which are both described in more 
detail below). 

 Show slicing plane: If a slice has been drawn in the Scene, this button will hide the slice. Once the 
slice has been hidden, the button can be clicked again to show the existing slice. 

 Show moving plane: As above, but for moving planes rather than for slices. 

 Select: Reverts the cursor to select mode. 

 Draw slicer line: Allows the user to draw a new slice through the Scene. Click the button, then 
click and drag in the Scene to create a slice. Once a slice has been drawn, a number of display 
options are available in the Scene List. 

 Draw plane line: Allows the user to draw a new plane in the Scene. Click the button, then click 
and drag in the Scene to create a plane. This is useful for defining the direction of global trends 
for surfaces. 

 Measure distances: Turns the cursor into a ruler. Click and drag the cursor from one object to 
another object to measure the distance between them.  
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Importing Data 
 
Before we import data, we need to firstly create a new project. 

 Go to the Projects tab at the top of the screen. 

 Click New Project. Give the project a name, and make sure it is being saved to a local location. 
 
To import any data into a Leapfrog project, Right-Click on the relevant folder in the Project Tree and 
select the "Import" option. 
 
Drill holes 
 
Drill hole information can be exported from acquire. Load the acquire workspace (Hamersley or Robe). 

 Go to 8. Export Data.  

 1. Run Configured Export 

 Select the Projectcode for the desired area and set the format as csv 

 Set the export location as your local drive.  

 Run Export 

AcQuire will export the drill hole information in the form of 6 Excel tables, 3 of which will be imported 

into Leapfrog. The three csv files to use are the Collar, Survey and Strand. Collar and Survey are both 

mandatory tables required within Leapfrog. It is important to ensure that all exports from acquire use the 

same grid system.  

In Leapfrog, go to your project tree and Right-Click Drillhole Data > Import Drillholes 

 

An Import Drillhole Data window will Display. Within this window, the file information will need to be 

populated. Next to the collar field, select Browse and navigate to the folder containing the acquire 

exported csv’s. 

one collar file: BS4_col.csv 
one survey file: BS4_surv.csv 
And one interval files: 
BS4_geolSTRAND 
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Once the three tables have been populated as above, select Import. Next the Leapfrog attributes will be 
assigned to columns within the excel tables. This will need to be completed for the three tables.  
 
Different columns from each table can be selected for importing into Leapfrog. There are several different 
data types that can be assigned to different columns upon import. It is important to make sure the data 
type for each column is selected correctly upon import, as there is no option to change the data type once 
the drillholes have been imported. 
 
Each of the different data types can be useful, but the four most commonly used data types are Lithology, 
Category, Text, and Numeric. 

 Lithology and Category data is treated the same in Leapfrog. Both can be used to create geological 
models. 

 Text data is imported into Leapfrog for visualisation but cannot be used to create models from. 

 Numeric data is used to create interpolant models. It is possible to create a "Category from 
Numeric" column from Numeric data once it has been imported into Leapfrog. 

 
Leapfrog does a search for common header names for each column, so some columns will be selected 
correctly for the import. 

 Columns which are highlighted green have been selected by Leapfrog based on the header of the 
column. These columns are required for the table to be imported. 

 Columns which are highlighted orange have been selected by Leapfrog based on the header of 
the column. These columns are optional and aren't necessary for the table to be imported. 

 Columns which are white, and not highlighted, haven't been selected by Leapfrog based on the 
header of the column. A data type can be assigned to these columns by clicking the dropdown 
box above each column and selecting the desired data type. If the data type is required for import, 
the column will be highlighted green, and if the data type is optional for import, the column will 
be highlighted orange (the same as the columns which are automatically selected by Leapfrog). 

 
 
Within the Collar field the following fields need to be import; HoleID, East, North, Elev and Max Depth. 
Click the column heading in Leapfrog and select the correct field. Leapfrog will have automatically 
assigned some of the fields for you.  
 
Note: If desired, project code can be imported as a category. You do not need to import all the columns.  
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Once all the columns have been attributed, click Next. 
 
The survey table will be attributed next. The mandatory fields needed to be assigned are: HoleID, Depth, 
Azimuth and Dip.  Again, Leapfrog will have populated some of these for you. To change or assign a new 
column, select the heading and then select the new field.  

 
Once all the columns have been attributed, click Next. 
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The last table to attribute is the strand table. To attribute multiple columns at a time, use the Column 
Summary field on the right-hand side. Press and hold the Shift key, then select the first field to import, 
Strand and then the last field to import, Geozone. Under the Import As Column, select the drop down 
menu for one of the select fields, and select Category. All three fields will import as a Category.  
 

 
 
Once all the columns have been attributed, click Finish. The drillholes will be imported into Leapfrog Geo.  
 
 
Appending Additional Drilling 
 
In Leapfrog it is possible to add new drilling to an existing project. This can be useful when looking at large 
areas with thousands of drillholes. Often multiple exports may be required from acquire to extract all the 
necessary data.  Instead of combining the excel files, additional tables can be appended into the 
workspace. This also allows you to expand existing projects as new information becomes available.  

 Right-Click on the Drillholes object and select Append Drillholes. 

 Follow the same steps as before, but instead select the new csv group.  
 
Validating Drilling 
 
After the import, the drillhole information can be validated using the available tools in Leapfrog. When 

errors or warnings exist in the database, these are signified by displaying a cross or an exclamation mark 

over the table. Firstly, export all existing errors and save as a csv by Right-Clicking Table > Export Errors. 

This keeps a record of the existing errors to be fixed in the database. Correcting the acquire database, will 

result in reduced errors over time. The errors can be viewed by Right Clicking Table > Fix Errors. The 

decision to correct the errors can be made on a project by project basis, based on the type and number 

of errors. As we are looking at regional extents, small errors in the database will have little effect on the 
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overall output. Typically, validation of the drillholes will be completed by Resource Evaluation as part of 

their modelling process.   

 

Note: Any errors or warnings in the collar and survey field will result in the hole not being displayed. 

Leapfrog is not a replacement for proper database management. We provide validation tools to allow you 

to create a reliable and accurate geological model.  However, it is recommended all errors are fixed in the 

database to save having to repeat this process again for future models.  

Other Data Import 
 

Topography 

Topographic data can be obtained several ways. For this work, the Pilbara 50k Contours data within the 

O drive should be acceptable. Within Mapinfo a clipping polygon can be used to extract the desired area. 

Ensure the area selected is larger than the area of interest. Export the Information from MapInfo as csv 

file.  

Contour data was imported through the Points folder. Right-Click Points > Import Points. Navigate to 

the exported MapInfo csv and double click the file to import it.  

 

Leapfrog will automatically assign the Easting, Northing and Elevation columns to the csv file. Confirm 

that these are correct and then select Finish.  
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Note: This is often quite a large file and may take several minutes to export.  

Additional data was also provided to help with modelling. Geological mapping was imported into Leapfrog 

as 3 separate georeferenced images. Right-Click GIS Data, Maps and Photos > Import Map.  

Water Table Contour 

The water table data will be supplied from the relevant hydrogeologist in the form of a shape file. To 

ensure the best coverage of data, it is recommended to provide them with a boundary to show the extents 

of the area of interest. Water table data of interest is the pre-mining surface, current surface and 

predicted LOM surface.  

To import into Leapfrog, Right-Click GIS Data, Maps and Photos > Import Vector Data. Navigate to the 

saved folder and select the file of interest. Press and hold Shift to select and import multiple files at a 

time. Select Open.  

 

A list of the files to import will display in a pop-up window. Uncheck the box for Filter Data. Select OK.  
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Once imported, the GIS files will be in 2D format. To covert to 3D format the elevation needs to be set 

using the file metadata. Right-Click the GIS File and select Set Elevation. 

 

In the Set Elevation pop up window, select the From attribute field and select Contour from the drop-

down menu. This will assign elevation data to each object and convert them to 3D. The elevation will need 

to be set for each individual GIS object.  

Click OK 

 

 

Other Meshes 

Pit shells and faults were also imported through the meshes folder Right-Click Meshes > Import Meshes. 

Navigate to the saved folder location and double click to import.  

Note: Some meshes contain self-intersections, which are represented with a "!" symbol over the mesh in 
the Project Tree.  
To check where the self-intersection is located, expand the black triangle to the left of the mesh, and drag 
the self-intersection into the Scene. 
Meshes with self-intersections are unable to be used for functions in Leapfrog requiring Manifold meshes. 
To fix the error, the mesh needs to fixed either in an external software package, or in the package it was 
originally produced, then reimported into Leapfrog. 
 
Mapping and Images 

Maps, geophysics or aerial photography can all be imported into Leapfrog as desired. To do so, Right-Click 

GIS Data, Maps and Photos > Import Map.  Navigate to the saved location and double click to import. If 

the map was georeferenced in MapInfo, you can move straight to the Import button. If not, you can use 

the three symbols to georeferenced the image within Leapfrog. A grid will be needed for this step.  
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Data preparation 
 

Legend 

To view the drilling information, select and hold the Strand table from the project tree and drag into the 

scene. The display category can be changed using the Scene List.  

 

To use the RTIO colour scheme, we can import the colour legends into Leapfrog. In the project tree, 

expand the Strand table and Right-Click the Strand category > Colours > Import. 

 

The latest colour templates are saved on the V drive (V:/Software/Leapfrog/Legends) as .lfc files. There 

will be one for each category (Legend_Strand, Legend_Tag, Legend_Geozone).  Import each one against 

the categories in Leapfrog. Colours can be customised by selected the Edit Colours option in the scene 

view.  
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A colour can be selected from the 20 default palette options, or using the colour wheel on the left.  

To display the legend in the scene, select the strand table in the scene list, and enable the Legend icon 

(furthest icon to the right).  

A copy of the legends can be found below: 

Legend_Strand.lfc
 

Legend_Tag.lfc
 

Legend_Geozone.lfc
 

 

Habitat Grouping 

The drillhole TAG information was grouped based on potential for Habitats. The groups are as follows: 

 

Table 1. Sub-fauna Habitat Potential Categories for Leapfrog Groups 

Sub-fauna Habitat Potential Categories 

High Medium Low 

HYD everything else DOR 

PIL  DOF 

PIW  CLA 

PIH  SHL 

CAV  SMN 

CAL  SHF 

HYW  SHC 

DOM   
<F>   
PIS   

 

To create the groups in Leapfrog, Right-Click the Strand table > New Column > Group Lithologies.  
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Set the base column as TAG and name this grouped stratigraphy Habitat_Ranking. 

 

In the following pop up window, all the available tags will be shown on the left under the field Ungrouped 

Lithologies.  To create a group, press and hold the Shift key and select the desired field for the High 

Category from the left-hand column.  
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Once all the correct tags have been selected, press New Group.  A new group will appear of the right-

hand column under Grouped Lithologies, which has combined the selected tags togethers. Name this 

group High. Use the arrow next to the code name to example the list. Once the group has been populated, 

you can add and remove tags by dragging and dropping them between groups or back to the ungrouped 

lithology column. Repeat the process for the Low and Medium categories using Table 1 above.  
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The Groups will be automatically linked to the 3D scene. As new groups are created and adjusted, the 

results will be displayed live. The colour for each group can be selected, by click the box for each code in 

the Colour column. Once the groups have been set, click OK.  

The default legend for Habitat Ranking can be found below and imported: 

RTIO_Habitat_Ranking.lfc
 

 

Note: The groupings can be adjusted at any time. To do so, double click the Habitat_Ranking category in 

the project tree. This will return you to the Lithology groupings window.  
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Additional Moderate Grouping 

If you are proceeding with Workflow 1 below (Basic Workflow), then this additional field will be required.  

An interval selection field will be used to create an additional grouping which combines the High and 

Medium fields together.  

To create the groups in Leapfrog, Right-Click the Strand table > New Column > Interval Select.  Set the 

base column as Habitat_Ranking and name this new field Habitat_Moderate. 

 

In the Interval Selection pop up window, turn the eyeball off for Low. Only High and Medium will now 

be displayed in the scene. Use the Select All button in the toolbar (Three lines with blue dotted halo) to 

select all visible intervals in the scene. Now that all High and Medium have been selected , in the pop up 

window, go to the Assign To drop down and select Create New Lithology. Call this new Lithology HM.  

 

You field will now have four categories; High, HM, Low and Medium. However, only two of them will 

contain intervals; HM and Low (as all High and Medium have been reassigned).  

Click the Save icon in the toolbar. Close the Interval Selection pop up window by selecting the X.  
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Strand Grouping 

If you are proceeding with Workflow 2 below (Geology Workflow), then this additional field will be 

required.  

An additional grouped field will be used to combine major strand and together and utilise geology fields 

as part of the habitat modelling process.  

To create the groups in Leapfrog, Right-Click the Strand table > New Column > Group Lithologies.  Set the 

base column as STRAND and name this grouped stratigraphy Grouped_Strand. 

 

Create a group for each of the major strand units as outlined in Table 2.  

Table 2. Grouped Strand Categories for Leapfrog Groups 

Major Strand Units 

FOR NEW WF DG WS JOF YS DET 

FOR NEW ANG FWZ WS JOF YS DET 

 N2U WF DG1 WS1 J1 WW DI 

 N2L MCS DG2 WS2 J2 WOV DM 

 NE1 MTS DG3  J3  CAL 

 MAC  DG  J4  CLA 

 NAM    J5  CA 

     J6  LI 

       PI 

       LIG 

       SID 

       COL 

       ROD 

 

Colours can be assigned manually by clicking the square in the colour column and selecting the 

appropriate colour from the palette.  
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When complete, select OK. 

Generating Meshes 
 

Topography 

A topography mesh can be created from the imported points. Right-Click Meshes > New Triangulated 

Mesh > From Points. Select the imported contour points from the Points folder. Next, we need to select 

the extents of the mesh. To do, ensure Own Extents is selected. The extents can be modified three 

ways.  

- Manual entry: Use the XYZ minimum and maximum fields to manual enter the extents you 

would like to use.  

- Use the Drop-Down option Enclose Object. This will apply a boundary that encompasses any 

available data.  

- Using the 3D scene: In the 3D scene the initial bounding box will be displayed. Use the red 

arrows to change the boundary of the easting and northing. The pink arrows control the vertical 

extents. The orange arrow cross will control the location of the box.  

For this exercise, option 2 will be used. Select Enclose Object > Drillholes > Strand. Leapfrog will give the 

mesh a default name. This can be changed if desired. Then select OK.  

Once the mesh was created, we need to set it as the default topography. To do this, Right-Click 

Topographies at the top of the project tree> Set Topography > From Meshes > Select the Triangulated 

Mesh you just created. 

Water Table 

A mesh for each of the water tables will also be needed. Right-Click Meshes > New Triangulated Mesh > 

From GIS Vector data. Select the imported water contour data from the GIS folder. Next, we need to 

select the extents of the mesh. As we have already set this previous, we can use the Shared with option. 
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From the Shared with dropdown select the topography. Repeat this process for each of the water 

contour files you have.  

Note: Using the New Triangulated mesh used the points from the data as vertices for the triangles in the 

mesh. This will result in faster generated meshes which is important when looking at large extents.  

You will also need to ensure the water table mesh is larger than the extents of the model. If this is not the 

case, the resulting mesh can be edited using a polyline to extend beyond the edges of the mesh. Right-

Click the mesh > Edit. The best option for editing is to draw a polyline on a slicer which has been set to 

the average RL of the water table. Click the slicer icon in the tool bar and use the properties panel to 

manually set the RL, dip and azimuth to a flat slicer plane at the desired RL. Ensure the draw on slicer 

option is activated.  

Geological Model 
 

Two workflows have been generated for process. Either one can be utilised depending on the resolution 

of the data and complexity of the geology. If data is sparse or geology overly complex, then it is 

recommended to use the Basic Workflow. The basic workflow contains the basic steps to create meshes 

that represents habitat ranking assignments generated earlier.  

The second Geology Workflow builds in a preliminary understanding on the geology of the area to 

better categorise and model the potential habitats locations.  

Basic Workflow 
 

Geological models in Leapfrog allow the user to put together a series of boundaries and surfaces to form 
an interlocking geological model. Geological models can be used to model any categorical data. 
 
Right-Click on the Geological Models folder and select New Geological Model. 
 
The New Geological Model window will appear, which lets you set several parameters for the geological 
model, including the base lithology column to use, the surface resolution, the model extents and the 
name. 

 Select the Habitat_Ranking column as the base lithology column 

 Change the surface resolution to 50 

 Change the name of the geological model to Habitat 

 Clear the Scene and drag the topography plus the drilling into the Scene. 
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 Click D to look down and use the arrows in the Scene to change the extents so they are inside 
the topography extents, and outside the drilling, as shown in the image below. 

 Use the Enclose Objects drop down to set the extents to the drilling.  

 Click OK to create the geological model.  
 

The boundary coordinate information for the Brockman 4 model are below. 

Table 3. Habitat Model extents 

36W-50W 

 Minimum Maximum 
X (East) 509000.0 545000.0 

Y (North) 7495000.0 7509000.0 
Z (Elev) 150.0 820.0 

 
 
Boundary Subfolder 
 
By default, all Leapfrog models are square or rectangular. We can add a number of extents to the 
geological model to adjust this to the desired shape. As we have defined a topography surface in the 
project previously, it has already been added as an upper extent of the geological model. 
 

 Check this by expanding the small black triangle to the left of the Boundary subfolder beneath the 
geological model. The Topography surface will be listed here. 

 Add a lateral extent by right clicking on the Boundary subfolder and selecting New Lateral Extent 
> From Surface. 

 Select a mesh such as a surface or modbox to constrain the boundary as needed. Click OK.  

 Review the new boundary. If the boundary is inverted, Right-Click on the surface under Lateral 
Extent and select Swap Inside.  
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For the Brockman 4 model, Lateral Extents were first manually generated in the Meshes folder. To use 
this option, first draw a plane in the scene by selecting the Draw Plane icon from the toolbar (second from 
the right).  
 

 Press D on the keyboard to ensure you are in Plane view.  

 Press and drag the mouse from left to right across the location you want the plane to be.  

 Once drawn, use the arrows on the plane to adjust as needed. The red arrows control the size, 
blue controls the azimuth and yellow controls the dip.  

 Ensure the plane is larger than the model boundary extents.  
 

 
 

 Right-Click Meshes > From Moving Plane 

 Set the Resolution to 100 and give the plane a name. 

 Click OK.  
 

 
 

Repeat the process again for the south boundary. As well as any other desired boundary extents.  
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Fault System Subfolder 
 
Faults can be added to the geological model using several different data types. The only requirement is 
that the fault completely intersects the boundaries of the geological model, otherwise Leapfrog has no 
way of splitting the boundary into different fault blocks. 
 
In this project, we will define the fault as the pre-mining water table. 
 

 Add the fault to the Fault System by right clicking on the Fault System and selecting New Fault > 
From Surface. 

 
 

 Select the pre-mining water table mesh and click OK. 

 To activate the faults, double click on the Fault System subfolder and check the checkboxes for 
the fault. 

 
 

 Click OK to accept the changes. This will force the geological model to re run, splitting it into three 
separate fault blocks. 
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Rename the three fault blocks so they are easy to identify, making sure the correct name is assigned to 
the correct fault block. The name to use are AWT and BWT.  
To view the fault blocks, Right-Click on the Geological Model and select View Fault Blocks.  To rename a 
fault block, Right-Click on the fault block and select Rename.  
 
Modelling in the Fault Blocks 
 
The first fault block to model will be the AWT. We will use the vein model functionality to generate two 
veins for each fault block.  
 

 Expand the AWT fault block to see the surface chronology by clicking the arrow 

 Right-Click on Surface Chronology > New Vein > From Base Lithology 
 

 
 Set the Vein Lithology as High 

 Name the Vein Lithology High 

 Select OK 
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 In the Project Tree, under Surface Chronology, the new Vein will be listed. Double Click on the 
Vein to view the properties.  

 Go to the Surfacing tab and check the box for Pinch Outs. Also, ensure that Boundary filter is set 
to Off. Click OK.  

 

 
 

Note: Due to the size of the area, the model will take some time to process. You can continue working 
during this time.  
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Next, we will repeat the process for the Medium field. To do this, we will want to use the HM field we 
generated earlier.  
 

 Right-Click on Surface Chronology > New Vein > Other Contacts 

 Use the Select Column Drop Down to change the column to Habitat_Moderate 

 Set the Vein Lithology as Medium. Leave the Outside Lithology as Unknown.  

 Select OK.  

 Set the Vein Lithology as HM. 

 Name the Vein Lithology Medium 

 Select OK 
 

 
 
 

 In the Project Tree, under Surface Chronology, the new Medium Vein will be listed. Double Click 
on the Vein to view the properties.  

 Go to the Surfacing tab and check the box for Pinch Outs. Also, ensure that Boundary filter is set 
to Off. Click OK.  

 
If geological mapping of the area is available, the vein can be further constrained by creating a boundary. 
This will need to be generated for each vein. Under the surface chronology, expand the selected vein by 
clicking the arrow.  
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 To change the boundary using a polyline, Right-Click on the boundary object ( ) in the project 
tree and select Edit. The current vein boundary will appear in the scene, together with drawing 
controls.  

 Press D to return to Plan View 

 Drag any geological mapping from the GIS folder into the scene 

 In the Scene list, adjust the opacity slider so you can see through the boundary plane and view 
the drilling and the mapping.  

 Begin drawing the new boundary, ensuring that the polyline drawn closes and does not intersect 
itself. 

 The polygon for the boundary should trace the base of Nammuldi contact with Fortescue and 
along the top of the Joffre unit.   

 When you save the boundary, the vein will be updated to reflect these changes. If you want to 

revert to the original boundary, Right-Click on the boundary object ( ) and select Delete 
Polyline. 

 

 
 
The above boundary polygon process was repeated for the Medium habitat vein.  
 
For further information on modifying veins, please view the Leapfrog Help Menu: 
http://help.Leapfrog3d.com/Geo/4.2/en-GB/Content/geo-models/veins.htm?Highlight=vein 
 
The two veins have now been generated for the AWT. We now need to conduct this process for the BWT 
fault block. Right-Click on the Surface Chronology for the AWT fault block > Copy Chronology to… 
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Select the BWT fault block and Select OK.  
 
The two veins will now be replicated in the BWT fault block.  
 
Next, we need to generate the output volumes for the model for both Fault Blocks (AWT and BWT).  

 Double click on Surface Chronology 

 Check the box next to High and HM to enable the veins 

 Set the Background Lithology to Low 

 Select OK 

 
 

 
Note: Ensure that the vein for High is sitting higher on the list than the vein for HM. The order of the 
surfaces in the list is import for determine the shapes of the output volumes.  
 
Repeat the process for the other fault block.  
 
To view the final model, Right-Click on the Geology Model > View Output Volumes.  
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Note: The output volumes can be used as the high, medium and low habitat locations. The meshes under 
the surface chronology for each fault block can be used individually to represent the different taxa.  
 

Geology Workflow 
 

This workflow will outline some basic steps to utilise the geology of the area to bound the potential habitat 

locations to major lithology types. This is based on the assumption that shale units present low potential 

for habitats whereas as BIF units present moderate potential for habitats. 

Right-Click Geological Models > New Geological Model.  

The New Geological Model window will appear, which lets you set a number of parameters for the 
geological model, including the base lithology column to use, the surface resolution, the model extents 
and the name. 

 Select the Grouped_Strand column as the base lithology column 

 Change the surface resolution to 50 

 Change the name of the geological model to Geology Model 

 Clear the Scene by pressing the bucket icon in the toolbar 

 Drag the topography and the drilling into the Scene. 
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 Click D to look down and use the arrows in the Scene to change the extents so they are inside the 
topography extents, and outside the drilling, as shown in the image below. 

 Use the Enclose Objects drop down to set the extents to the drilling.  

 Click OK to create the geological model.  
 

The boundary coordinate information for the Brockman 4 model are below. 

Table 3. Habitat Model extents 

36W-50W 

 Minimum Maximum 
X (East) 509000.0 545000.0 

Y (North) 7495000.0 7509000.0 
Z (Elev) 150.0 820.0 

 
 
Boundary Subfolder 
 
By default, all Leapfrog models are square or rectangular. We can add a number of extents to the 
geological model to adjust this to the desired shape. As we have defined a topography surface in the 
project previously, it has already been added as an upper extent of the geological model. 
 

 Check this by expanding the small black triangle to the left of the Boundary subfolder beneath the 
geological model. The Topography surface will be listed here. 

 Add a lateral extent by right clicking on the Boundary subfolder and selecting New Lateral Extent 
> From Surface. 

 Select a mesh such as a surface or modbox to constrain the boundary as needed. Click OK.  

 Review the new boundary. If the boundary is inverted, Right-Click on the surface under Lateral 
Extent and select Swap Inside.  
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For the Brockman 4 model, Lateral Extents were first manually generated in the Meshes folder. To use 
this option, first draw a plane in the scene by selecting the Draw Plane icon from the toolbar (second from 
the right).  
 

 Press D on the keyboard to ensure you are in Plane view.  

 Press and drag the mouse from left to right across the location you want the plane to be.  

 Once drawn, use the arrows on the plane to adjust as needed. The red arrows control the size, 
blue controls the azimuth and yellow controls the dip.  

 Ensure the plane is larger than the model boundary extents.  
 

 
 

 Right-Click Meshes > From Moving Plane 

 Set the Resolution to 100 and give the plane a name. 

 Click OK.  
 

 
 

Repeat the process again for the south boundary. As well as any other desired boundary extents.  
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Modelling the Stratigraphy 
 
For this model we will generate some basic surfaces to represent the different stratigraphic units in the 
area. We will use the Stratigraphic sequence tool.  
 

 Right-Click on Surface Chronology > New Stratigraphy 
 

 

 In the pop-up window, use the dropdown menu to first fill in the Lithology Above as the youngest 

strand, which in this case is YS.  

 Then fill in the Lithology Below and the oldest unit, FOR.  

 In the central area, click Add Lithologies and use the tick-box to select all the stratigraphic 

lithologies; JOF, WS, DG, WF and NEW.  

 

 Leapfrog will automatically try to assign them to the correct stratigraphic order. If the order is 

incorrect, use the Younger and Older buttons on the left-hand side to re-order.  

 Select OK. 

Leapfrog will create surfaces for the contacts between all the stratigraphic units. To view the results, click 

and hold Stratigraphic Sequence under Surface Chronology and drag into the scene.  
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The next surface to make is the base of detritals.  

 Right-Click on Surface Chronology > New Intrusion > From Base Lithology 

 

 
 Select the Interior Lithology as DET 

 Leave all the stratigraphic units as Exterior Lithologies.  

 Name the surface DET. 

 

To view the results, click and hold DET under Surface Chronology and drag into the scene. 
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To create the output volumes from the surfaces, the next step is to activate the surfaces.  

 Double click on Surface Chronology 

 Tick the box for DET and Stratigraphic Sequence 

 Leave the Background Lithology as Unknown.  

 Select OK.  

 

To view the final model, Right-Click on the Geology Model > View Output Volumes.  
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Now that we have basic volumes for each of the different stratigraphic units, these can be used to create 
a refined model.  
 
Refined Model 
 
The refined model will be used to model habitat potential within each strand.  
 

 Right-Click the Geological Models folder > New Refined Model 
 

 
 

 The Model to refine will be the Geology Model 

 Lithology to Refine will be DET 

 The Base Lithology column will be Habitat_Ranking 

 The Surface Resolution will be 50 

 Name the model Habitat Ranking 

 Select OK 
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Repeat the above process for each of the lithologies. Each time, all the parameters will remain the same, 

but the Lithology to Refine will change. Repeat for YS, JOF, WS, DG, WF, NEW and FOR.  

 

Each strand volume will now be able to be further modelled within.  

We will continue working with the assumption that shale units present low potential for habitats whereas 

as BIF units present moderate potential for habitats. For this reason, DET, JOF, DG and NEW will follow 

the next steps.  

 Use the arrow next to DET to expand in the project tree.  

 Right-Click on Surface Chronology > New Vein > From Base Lithology 
 

 
 Set the Vein Lithology as High 

 Name the Vein Lithology High 

 Select OK 

 
 

 In the Project Tree, under Surface Chronology, the new Vein will be listed. Double Click on the 
Vein to view the properties.  
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 Go to the Surfacing tab and check the box for Pinch Outs.  

 Ensure that Boundary filter is set to Off.  

 Click OK.  
 

 
 

Note: Due to the size of the area, the model will take some time to process. You can continue working 
during this time.  
 

 
 

Next, we will repeat the process for the Low category.  
 

 Right-Click on Surface Chronology > New Vein > From Base Lithology 

 Set the Vein Lithology as Low. 

 Name the Vein Lithology Low 

 Select OK 
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 In the Project Tree, under Surface Chronology, the new Low Vein will be listed. Double Click on 
the Vein to view the properties.  

 Go to the Surfacing tab and check the box for Pinch Outs.  

 Ensure that Boundary filter is set to Off.  

 Click OK.  
 

Next, we need to generate the output volumes for the model.  

 Double click on Surface Chronology 

 Check the box next to High and Low to enable the veins 

 Use the Younger button the left side to ensure High is sitting at the top of the list.  

 Set the Background Lithology to Medium 

 Select OK 

 
 

Repeat this process for JOF, DG and NEW.  
 
For WF and WS, the following steps will be applied.  
 

 Use the arrow next to WF to expand in the project tree.  

 Right-Click on Surface Chronology > New Vein > From Base Lithology 
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 Set the Vein Lithology as High 

 Name the Vein Lithology High 

 Select OK 

 
 

 In the Project Tree, under Surface Chronology, the new Vein will be listed. Double Click on the 
Vein to view the properties.  

 Go to the Surfacing tab and check the box for Pinch Outs.  
 Ensure that Boundary filter is set to Off.  

 Click OK.  
 

 
 
The rest of the unit will be assumed to be low potential for habitat.  

Next, we need to generate the output volumes for the model.  

 Double click on Surface Chronology 
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 Check the box next to High to enable the vein 

 Set the Background Lithology to Low 

 Select OK 

 
 

Repeat this process for WS.  
 
For YS we will assume low potential for the whole unit.  
 

 Expand YS by selecting the arrow in the project tree 

 Double click on Surface Chronology 

 Set the Background Lithology to Low 

 Select OK 
 

 

 

To view the outputs of the refined model, Right-Click on the Refined Model, and select View Output 

Volumes.  



Habitat Modelling – Workflow Process Document 

42 | P a g e  
 

 

Water Table Model 
 

To create individual habitat locations for the Troglofaunal and Styglofaunal habitats, a model will be 

generated of the water table. By using the different water tables, we can later review how habitats will 

change as mining develops.  

Right-Click Geological Models > New Geological Model.  

The New Geological Model window will appear. 

 Select None as the base lithology column 

 Change the surface resolution to 50 

 Change the name of the geological model to Water Table. 

 Use the Enclose Objects drop down to set the extents to the previous Habitat Model 

 Click OK to create the geological model.  
 

The boundary for the water table model will be set to the same as the previously generated habitat 

models.  

 Add a lateral extent by right clicking on the Boundary subfolder and selecting New Lateral 
Extent > From Surface. 

 Select a mesh used earlier.  

 Click OK.  

 Repeat for second mesh. 

 Review the new boundary. If the boundary is inverted, Right-Click on the surface under Lateral 
Extent and select Swap Inside.  

 
As the Base Column for the model was set to None, the lithologies will need to be added in manually.  

 Double Click Lithologies in the Project Tree.   

 Select Add to create a new Lithology.  

 Name the new Lithology AWT.  
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 Repeat for BWT, Current and LOM.  

 Use the box in the colour column, to customise the colours as desired.  

 Select OK.  
 

 
 

The water table will be modelled using the surfaces we generated earlier.  

 Right-Click on Surface Chronology > New Erosion > From Surface 
 

 
 

 Select surface from the meshes folder. The first surface will be the pre-mining water table.  

 Set the First Lithology as AWT 

 Leave the Second Lithology as Unknown 

 Name the surface AWT 

 Select OK 
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Repeat the process for the current Water table and the LOM water table. For each surface, select the 

correct surface from the meshes folder and assign the First Lithology as Current and then LOM for the 

second surface.  

This will result in three erosional surfaces available under the surface chronology.  

 

Next the surface chronology will be activated to obtain the output volumes.  

 Double click Surface Chronology 

 Check the box next to AWT, Current and LOM to enable the erosional surfaces 

 Use the Younger button the left side to ensure the order is correct. AWT at the top, then Current 
and LOM is last.   

 Set the Background Lithology to BWT 

 Select OK 
 

 

To view the outputs of the water table model, Right-Click on the Geological Model, and select View 

Output Volumes.  
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Pit Model  
A geological model of the pit was generated. Creating a pit model will allow the geological model to be 

separated into Pit and In Situ material and view the habitat locations based on mining development 

stages.   

Pit information was provided in the form of polylines from Vulcan in a dxf format.  The pit design was 

imported into Leapfrog. Right-Click Polylines > Import Polyline. 

The pit surface was first re-created within Leapfrog.  A new triangulated mesh was generated from the 

polyline and new points.  

 Right-Click Meshes > New Triangulated Mesh > From Polyline   

 Shared Extents with Topography 

 Name the Mesh using the Pit Name 

 Select OK 

 Select Existing Polyline checkbox and then select the Pit polyline. 

 Right-Click on the mesh object > Add > Polylines. Select the next polyline.  

 Repeat this step until all polylines have been added to a single mesh.  
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A series of polylines were created outside of the pit and model extents to help extend the edges of the 

mesh outside the modelling area. Polylines were drawn well above the topography. If the pit mesh is 

smaller than the model extents, it cannot be used in a Leapfrog geological model.  

 

 

Right-Click Geological Models > New Geological Model.  

The New Geological Model window will appear. 

 Select None as the base lithology column 

 Change the surface resolution to 50 

 Change the name of the geological model to Pit Model 

 Use the Enclose Objects drop down to set the extents to the previous Habitat Model 

 Click OK to create the geological model  
 

The boundary for the pit table model will be set to the same as the previously generated habitat models.  

 Add a lateral extent by right clicking on the Boundary subfolder and selecting New Lateral 
Extent > From Surface. 
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 Select a mesh used earlier.  

 Click OK.  

 Repeat for second mesh. 

 Review the new boundary. If the boundary is inverted, Right-Click on the surface under Lateral 
Extent and select Swap Inside.  

 
As the Base Column for the model was set to None, the lithologies will need to be added in manually.  

 Double Click Lithologies in the Project Tree.   

 Select Add to create a new Lithology.  

 Name the new Lithology Pit  

 Repeat for In Situ and any additional mining pit stages.  

 Use the box in the colour column, to customise the colours as desired.  

 Select OK.  
 

 

 

The new triangulated mesh pit was then modelled within the pit.  

 Surface Chronology > New Erosion > From Surface > Select the New Triangulated Mesh Pit.   

 The lithology for this new surface is First Lithology Pit and Second Lithology In Situ.  

 Name the surface Pit 

 Select OK 
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Next the surface chronology will be activated to obtain the output volumes.  

 Double click Surface Chronology 

 Check the box next to Pit 

 Set the Background Lithology to In Situ 

 Select OK 
 

 

To view the outputs of the water table model, Right-Click on the Geological Model, and select View 

Output Volumes.  

 

Combined Model 
 

Combined models can take information from up to four geological models, interpolants or distance 
functions, which allows relationships between different data types to be easily visualised. The combined 
model has been used in this workflow to divide the High and Medium potential habitats by the water table 
and differentiate Troglofaunal and Stygofaunal habitats. The combined model functionality can be found 
towards the bottom of the project tree through a folder called Combined Models.  
 
Habitat_Ranking and Water_Table 
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To create a combined model 

 Right-Click Combined Model > New Combined Model 

 The refined model for Habitat Ranking and Water table model were selected.  

 Name the combined model Taxa over Time 

 Select OK 

 
 

 The volumes to combine were then selected. All the Water Table volumes were selected; AWT, 

Current, LOM and BWT.  

 For Habitat_Ranking, only the High and Medium volumes were selected.   

 The order of the models listed in the window is important. The model at the top will be the Main 

model and will be subdivided by the second model.  

 Select OK 

 

A new combined model will be available under the Combined Models folder.   

To view the output volumes, expand the combined model in the project tree by selecting the arrow.  

Right-Click on the Output Volumes.  

You can select to view the Child Volumes. In this case it is the Water Table Model. To view the Habitat 

Ranking subdivided by water table, select View Leaf Volumes.  
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Alternatively, you can drag the individual volumes onto the scene as desired.  

 

The High habitat potential areas are shown above. These are divided into 4 volumes.  

AWT, High = Original High Potential Troglofauna habitat.  

Current, High = Current High Potential Troglofauna habitat. This represents new habitats for troglofaunal 

since the change in water table that were original stygofauna habitats.  

LOM, High = Future High Potential Troglofauna habitat. This represents potential new habitats for 

troglofaunal aft the completion of mining.  At this point in time, they present current Stygofauna habitats.  

BWT, High = Current Stygofauna habitats.    

This is best seen in cross section view.  
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Habitat_Ranking and Water_Table and Pit 
 
 
A combined model can also be generated taking into account current and future pit designs. A combined 

model of all three models was generated.   

To create a combined model 

 Right-Click Combined Model > New Combined Model 

 The refined model for Habitat Ranking, Water table and Pit model were selected.  

 Name the combined model Taxa Pit 

 Select OK 

 

 The volumes to combine were then selected. All the Pit and Water Table volumes were 

selected; Pit, Situ and AWT, Current, LOM and BWT.  

 For Habitat_Ranking, only the High and Medium volumes were selected.   
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 The order of the models listed in the window is important. The model at the top will be the Main 

model and will be subdivided by the second model. The order here will be Pit, Water Table and 

Habitat Ranking.  

 Select OK 

 

Use the arrow to expand the output volumes and drag the individual volumes onto the scene to view.  

Below is an image of the sub-fauna split into habitats within the final pit design and outside the final pit 

design.  

 

The sub-fauna can now be displayed divided by both water table level and pit location.  
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The high and medium habitat potential areas are shown above. These are divided into 16 volumes.  

Pit, AWT, High = Original High Potential Troglofauna habitat within final pit design.  

Pit, Current, High = Current High Potential Troglofauna habitat. This represents new habitats for 

troglofaunal since the change in water table that were original stygofauna habitats within final pit design.  

Pit, LOM, High = Future High Potential Troglofauna habitat. This represents potential new habitats for 

troglofaunal aft the completion of mining.  At this point in time, they present current Stygofauna habitats 

within final pit design.  

In Situ, BWT, High = Current Stygofauna habitats outside the final pit design.    

In Situ, AWT, High = Original High Potential Troglofauna habitat outside the final pit design.  

In Situ, Current, High = Current High Potential Troglofauna habitat. This represents new habitats for 

troglofaunal since the change in water table that were original stygofauna habitats outside final pit design.  

In Situ, LOM, High = Future High Potential Troglofauna habitat. This represents potential new habitats for 

troglofaunal aft the completion of mining.  At this point in time, they present current Stygofauna habitats 

outside the final pit design.  

In Situ, BWT, High = Current Stygofauna habitats outside the final pit design.    

The same divisions can be found for the medium potential habitats.  
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Volume 

The volumes of Combined Models or any mesh within Leapfrog can be found by right clicking on the 
Output Volume of interest and selecting Properties. Another way of accessing the volume is by clicking on 
the Output Volume in the Scene, which brings up a small properties panel in the Scene.  
 

 
 

Thickness Grid 
 

Export 

A Thickness grid can be generated and exported for any mesh within Leapfrog. This can then be 

transferred to MapInfo. 

Right-Click on the desired output volume > Export Thickness Grid 

 

The grid spacing will need to be defined. This should be similar to the drill hole spacing. For Brockman 4, 

a 50m by 50m grid was used.  
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Click Export. 

Navigate to the desired export drive location.  

Note: The smaller the grid, the longer the export will take. 50m by 50m was approximately several minutes. 

Larger grid spacing will export faster however will result in coarser contours within MapInfo.  

If the desired mesh is from a combined model, the thickness grid export will not be directly available. The 

mesh will need to be extract first to the meshes folder.  

Right-Click on the combined model mesh > Extract Mesh Part 

 

Select All. 

Select OK. 
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A static copy of the mesh will now be available under the Meshes folder. Locate the mesh under the 

meshes folder and Right-Click > Export Thickness Grid.  

This will export a 2D thickness grid in ascii format.  

Import 

The exported thickness grid can be viewed in Leapfrog.  

 Right-Click GIS Data, Maps and Photos > Import 2D Grid 

 

 Navigate to the correct folder and double click the desired grid 

 

Once imported, the ascii grid will be available under the GIS folder. To import a default colour scheme, 

expand the grid by clicking on the arrow in the project tree.  

 Right-Click on Band1 > Colours > Import 

 

 Navigate to the Habitat Thickness legend file and double click to load.  

 Select OK on the pop up window.  

The default colour legend for thickness is available below: 

RTIO_Habitat_Thickness.lfc
 

 

To view the thickness grid in Leapfrog, click and drag from the project tree into the scene. The legend can 

be adjusted by using the legend drop down.  
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Leapfrog Viewer 
 

Leapfrog Viewer is a small Windows desktop application which allows users to easily open and explore 3D 
scene files (*.lfview) created in other Leapfrog modelling products.  Users can visualise the models right 
as they were created, with consistent colouring, rendering and widget setups such as in-scene slicer and 
moving plane.  

Leapfrog Viewer allows modelling geologists to share their work with those who do not have a Leapfrog 
dongle, or don’t have the skills yet to use Leapfrog. It is also a way for users to share their results and 
findings with managers and other stakeholders. Leapfrog View provides a great tool for model 
presentations and handovers in a 3D scene as an alternative to static PowerPoint slides.  

Leapfrog Viewer is currently unrestricted for anyone to download and use and requires no internet 
connection. Leapfrog Viewer can be downloaded from the following website: 
https://www.Leapfrog3d.com/products/Leapfrog-viewer/downloads 

 

Saving Scenes 
 
The results of the model will be displayed as a series of scenes that can be displayed in Leapfrog Viewer. 
To create a scene: 

 View the raw data in the Scene, including the drilling and the topography. Display the drilling by 
Habitat_Ranking.  

 Save the Scene by right clicking on the Saved Scenes and Movies folder in the Project Tree and 
selecting Save Current Scene. 
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 Give the Scene a description and change the name of the Scene.  
 

Note: Scenes will be listed in the Project Tree in alphabetical order, so by naming them using a number 
followed by the descriptive name, they will be listed correctly (eg. 1. Raw Data, 2. High Potential Habitat, 
3. Habitat with Faults, 4. Combined Model etc). 
 

 Click OK and the Scene will be saved. 
 

 
 

 Repeat until there are several saved scenes that describe each part of the modelling process. 
Select different items to display for each scene.  

 Clear the scene. 
 
When the saved scene is dragged back into view, the same settings including objects, slicer and 
transparencies are remembered.  A good habit to get into is to save scenes as you progress through a 
model, describing the steps that were taken to build it and pointing out important or interesting 
features of the model. 
 
Exporting to Leapfrog Viewer 
 
Once scenes have been saved in your Leapfrog project, you can export them and open them in the 
Leapfrog Viewer, which is free software available on the Leapfrog3d website. Leapfrog Viewer allows the 
user to rotate, zoom, slice, change the transparency and view the details (volume etc) of each object in 
the saved scene. 
 
If you have the Leapfrog Viewer installed on your computer, you can work through the following steps: 

 Right-Click on the Saved Scenes and Movies folder and select Export Scenes. 

 Double click on the Scenes you would like to export to move the Selected Scenes panel.  
 
Note: There are two options on the next window which can be selected to change the data which is 
exported. The first is the "Export Hidden Shapes" checkbox. When selected, this will export any shapes 
which are in the scene but hidden at the time the scene was saved. The second is the "export shapes only" 
or "export all data that appears when I click" option. When the second option is selected, data that appears 
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in the Leapfrog scene when an object is clicked on, such as the volume, area, elevation, and location, is 
exported. When the first option is selected, the data is not exported. 
 

 
 

 Choose the options you would like as above and click Export. 

 Enter a file name, then click Save. 

 Open the Leapfrog Viewer and navigate to your exported Saved Scenes to open them. 

A quick guide to using Leapfrog Viewer can be found on the final page of this document.  

Supplementary Information 
 

One of the biggest benefits of Leapfrog is the ability to dynamically update projects as new data comes in.  

For this reason, keeping workspaces clean and tidy is important for future users of the project.  

Subfolders 

Subfolders can be created to sort and store information within Leapfrog. To create a subfolder: 

 Right-Click on the folder > New Subfolder… 

 

 Give the new subfolder a name.  
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Objects within Leapfrog can be moved between folders, by clicking and holding and then dragging and 

dropping to a new subfolder.  

 

Comments 

Comments can be assigned to folders and objects within Leapfrog. This allows future users to understand 

the modelling and thought process. To create a comment: 

 Right-Click on the folder or object 

 Move your mouse to the right of the drop-down list to where it says ‘No Comments’ and click the 

mouse within the yellow box.  

 Enter your comment 

 Use the Insert dropdown to add Date and Time stamp your comments 

 

 

When comments are attached to a folder or object a small speech bubble icon will appear to the left of 

the object name. The comments will be visible anytime someone right-clicks on the folder or object.  



 
 

 

 


